Единый форум поддержки

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.


Вы здесь » Единый форум поддержки » Информация сервиса » Поддержка HTTPS


Поддержка HTTPS

Сообщений 161 страница 180 из 351

1

Интегрирую постепенно сертификаты на форумы, чтобы обеспечить их работу по HTTPS.
Полного переезда на HTTPS для всего сервиса не планируются. Форумы будут работать и по HTTP и по HTTPS. Но поисковикам будет приоритет именно на HTTPS версию.
Однако, отдельные форумы могут переехать на HTTPS по своему желанию, планирую добавить соответствующую опцию в настройки.

Плюсы у HTTPS относительно HTTP следующие:
1. Большая защищенность. Как побочный эффект, провайдеры не могут добавлять свою рекламу в HTTPS версию. Как минимум, добавлением рекламы грешат ростелеком и мегафон.
2. Отсутствие надписи "не защищено" в браузерах. Некоторых новых пользователей такая надпись может отпугивать.
3. Поисковики (google точно) выше ранжируют HTTPS сайты. Выигрыш незначительный, это один из сотен факторов ранжирования, но он несомненно присутствует.
4. Работа по протоколу HTTP/2, который позволяет в некоторых случаях быстрее загружать страницу даже несмотря на её шифрование.
5. Более точная статистика (в метрике яндекса, аналитике гугла, или любого другого сервиса). Трафик с https сайтов на http форум считается прямым, а не реферальным.

Возможно уже и ваш сайт работает по https, просто введите в адресной строке браузера https:// перед именем форума и смотрите. Вероятно, чтобы браузер признал сайт безопасным необходимо будет в стилях и некоторых скриптах менять ссылки. Они находятся не в коде форума, поэтому невозможно поменять автоматически. Если же делать скрипт и менять все залитые css/js файлы, то есть риск что-нибудь сломать.

В админке следующие опции:
1. HTTPS для поисковиков. При выборе этого варианта на каждой странице добавляется canonical с https версией. Соответственнно, поисковики по мере индексации будут сохранять именно https страницу и через какое-то время в поисковиках останется только HTTPS версия сайта. Вероятно, этот вариант эквивалентен переезду сайта из яндекс.вебмастер или изменению адреса в google search console.
2. Переадресовать на HTTPS. Здесь всё просто, включается перенаправление на https версию. Но нужно уточнить, используется код 302, а не 301. По идее, в данном случае нужно 301 использовать, но тогда и браузер запоминает перенаправление, а это может быть чревато, если администратор просто экспериментирует с настройками.
3. HTTP. Оставить всё как есть, никаких canonical, никаких перенаправлений.

+16

161

sshmmv
Предупреждение за агрессию и бан на месяц по сумме предупреждений. Плюс вторая пометка ‡. После третьей следует бан навсегда.
Проблемы на Вашем форуме, кстати, не увидел.

0

162

Alex_63 написал(а):

Проблемы на Вашем форуме, кстати, не увидел.

А здесь?: Одно сообщение и Другое сообщение

sshmmv написал(а):
kernel написал(а):

А теперь посмотрите в код страницы... Это у вас какой-то скрипт меняет ссылки

Этот скрипт:

kernel написал(а):

Замена происходит в реальном времени при выводе сообщения

В сообщениях форума просмотрел штук 50 ссылок на сторонние сайты на http. Часть из них не измененные, а часть – в свойствах ссылки префикс изменен на https. Соответственно, такая ссылка отправляет на не существующий сайт с https в адресе.
Доходит до смешного: в сообщении идет подряд 5 ссылок на 5 разных страниц одного и того же стороннего сайта на http, но самая первая ссылка (свойства ссылки) в сообщении переписана на https, а следующие четыре – не измененные, с http в свойствах, как и положено. Или: в сообщении не измененная ссылка, с http, а в цитате из этого сообщения ссылка (свойства ссылки) уже переписана на https. Или вообще, сообщение с одной и той же ссылкой, но написанной 2 раза – первая ссылка осталась нормальная, вторая ссылка переписанная:

Скрытый текст:

Для просмотра скрытого текста - войдите или зарегистрируйтесь.

Причем, закономерностей этому ни каких нет, всё случайным образом.

sshmmv написал(а):
kernel написал(а):

Вы же заметили, что на этом форуме нет такой проблемы и что она есть только у вас?

kernel
--> https://forum.mybb.ru/search.php?action … 2%E8%F2%FC

https://i.imgur.com/QX41FPal.png

https://i.imgur.com/pJUDYdNl.png

https://i.imgur.com/UhywajWl.png

Устраняйте проблему!

Я – вижу. Вы с kernel – нет. Странно?

0

163

wodox написал(а):

А здесь?: Одно сообщение и Другое сообщение

Тут да, была проблема. Исправлено, спасибо.
Проблема возникала, только если перед ссылкой шло изображение с https.

0

164

Alex_63 написал(а):

Проблема возникала, только если перед ссылкой шло изображение с https.

В сообщениях на скрине, в сообщениях в поиске, да и в самих сообщениях в темах: https://forum.mybb.ru/search.php?action … 2%E8%F2%FC  нет изображений с https. Да и вообще нет ни каких изображений.

Alex_63 написал(а):

Исправлено

Да, вижу.
До исправления слово https в адресной строке хрома было зеленого цвета, а сейчас серого. До исправления система protect показывала зеленый запертый замочек, а сейчас открытый серый.

Alex_63 написал(а):

Тут да, была проблема. Исправлено, спасибо.

Хоть я не участник конфликта между kernel и sshmmv, а просто свидетель, но как свидетель свое мнение выскажу: если бы kernel отнесся к делу так же, как Вы, то и конфликта не возникло. Из-за поведения и действий kernel пострадал человек, который нашел и показал вам проблему. Не я заслуживаю Вашу благодарность:

Alex_63 написал(а):

спасибо.

а sshmmv.

Всего хорошего!

Добавлено спустя 25 минут 22 секунды:

Не знаю, это очередная неисправность или так задумано, но в моем профиле и здесь показано, что у меня Сообщений: [ 0 ]

Отредактировано wodox (Вс, 19 Апр 2020 09:01:37)

0

165

wodox написал(а):

В сообщениях на скрине, в сообщениях в поиске, да и в самих сообщениях в темах: https://forum.mybb.ru/search.php?action … 2%E8%F2%FC  нет изображений с https. Да и вообще нет ни каких изображений.

По вашему мнению смайлы не являются картинками?

0

166

wodox написал(а):

До исправления слово https в адресной строке хрома было зеленого цвета, а сейчас серого. До исправления система protect показывала зеленый запертый замочек, а сейчас открытый серый.

да,незащищенно

0

167

wodox написал(а):

в самих сообщениях в темах: https://forum.mybb.ru/search.php?action … 2%E8%F2%FC  нет изображений с https.

На этом форуме в приведенных примерах и проблемы не было.
А вот в поиске на cebro.mybb.ru были изображения и ошибочная замена на https.

wodox написал(а):

До исправления слово https в адресной строке хрома было зеленого цвета, а сейчас серого. До исправления система protect показывала зеленый запертый замочек, а сейчас открытый серый.

Это где именно? Перешел по ссылке, где сообщения из поиска на форуме cebro.mybb.ru, вижу там в адресной строке иконку защищенного соединения, как и до исправлений.

wodox написал(а):

если бы kernel отнесся к делу так же, как Вы, то и конфликта не возникло. Из-за поведения и действий kernel пострадал человек, который нашел и показал вам проблему.

По правде сказать, kernel относится к делу еще более внимательно и серьезно, чем я, поверьте)
Но искать баг на целой странице с сообщениями, в которых часть имеют проблему, а часть нет - довольно сложно, я тоже проблему не сразу заметил, нужно было хотя бы на конкретный пост с проблемой ссылку дать.
Ну и sshmmv пострадал исключительно по своей вине. Нужно держать себя в руках, тогда проблем не будет, мы всегда выслушаем и поможем, если есть чем. А это уже не первый его подобный прокол.

+3

168

Если у вас что-то поломалось и проблемы явно технического характера (не относящиеся к ошибкам верстки), если перестали работать вдруг какие-то функции — просьба сообщать об этом здесь или на ЕТП. Лучше сразу на ЕТП

Доброго дня, не знаю, указывали ли вам на такие ошибки, но вот:
- перестала работать функция "наградки" (на хттпс - не работает, хттп - работает) ;
- пропала возможность оставлять комментарии к постам ( на хттпс - плюсы без возможности коментов, на хттп - работает нормально)

Проверяла на нескольких форумах русфф переводя их на хттпс.

Скрытый текст:

Для просмотра скрытого текста - войдите или зарегистрируйтесь.

Отредактировано lacky (Вт, 21 Апр 2020 14:32:52)

0

169

lacky
Доброго дня.
Дополнения Rusff пока что не работают с https, потому на этой версии сайта не подгружаются.
Об этой проблеме в курсе.

+1

170

В форме ответа, при вставке видео с youtube, ссылка вида https://youtube.com/watch?v=xxxx преобразуется в ссылку вида http://youtube.com/watch?v=xxxx
Пора это исправить, одновременно надо переименовать в сообщениях форумов все старые ссылки с http://youtube.com на https://youtube.com

Отредактировано wodox (Вс, 26 Апр 2020 12:27:46)

0

171

Всем здравствуйте! Подскажите что делаю не так... Прочитала тут что:

Если Ваш форум, открытый по протоколу https://, всё ещё не определяется браузером как безопасный (пометка "Не защищено"), возможно, на страницах есть так называемый смешанный контент, загружаемый по протоколу http://. Это могут быть изображения, файлы стилей и т.д. Нужно проверить используемые скрипты и стили на наличие URL-адресов, содержащих http, и исправить их на https. Если всё будет сделано правильно, пометка "Не защищено" должна исчезнуть.

Уже по-всякому на своём форуме проверяла ссылки с http:// и поиском и в ручную. И каждый файл скрипта открывала и проверяла, даже убирала все скрипты и добавляла по одному - безрезультатно.  Уже кажется везде где можно заменила и проверила, а оно всё равно не защищено... Хотя в админке пометки "Не защищено" нет.

Кто-нибудь может подсказать что я пропустила? Или каким образом можно найти проблемный скрипт?

Отредактировано Мэрилин Мэрис (Вс, 26 Апр 2020 15:37:41)

0

172

Мэрилин Мэрис написал(а):

Уже по-всякому на своём форуме проверяла ссылки с http:// и поиском и в ручную. И каждый файл скрипта открывала и проверяла, даже убирала все скрипты и добавляла по одному - безрезультатно.  Уже кажется везде где можно заменила и проверила, а оно всё равно не защищено... Хотя в админке пометки "Не защищено" нет.

На главной и странице тем всё нормально, на странице сообщений:

#dice {display: inline-block; width: 25px; height: 25px; margin: 0 0 -7px 9px; background: transparent url('http:// forumstatic.ru/files/0015/1e/ae/66265.png') no-repeat 0px center;}

Отредактировано kolobdur74 (Вс, 26 Апр 2020 16:20:08)

+2

173

kolobdur74
Спасибо большое! Я не заметила это, оказывается...

Теперь защищено и всё работает, кроме подфорумов. Они отображаются только на главной, а вот на странице списка тем в главном форуме (тут например) не отображаются. 

Это можно как-то исправить?

+2

174

Мэрилин Мэрис
Спасибо, нашел источник проблемы, поправлю вместе с остальными правками (по автоустановке).

0

175

Alex_63 написал(а):

Мэрилин Мэрис
Спасибо, нашел источник проблемы, поправлю вместе с остальными правками (по автоустановке).

А можно и тогда заодно "быстрый переход" поправить? Он тоже не работает на https.

Отредактировано Мэрилин Мэрис (Вс, 26 Апр 2020 20:43:26)

+1

176

Мэрилин Мэрис
Думаю, что да.

0

177

Alex_63 написал(а):

Мэрилин Мэрис
Думаю, что да.

Спасибо, тогда буду ждать правок в обоих скриптах.

0

178

Мэрилин Мэрис
Исправил проблемы совместимости с https во всех версиях подфорумов (включая автоустановку в админке) и в быстром переходе. Если не работает, нужно почистить кэш браузера и/или обновить страницу используя Ctrl+F5.

+1

179

Alex_63
Быстрый переход работает, спасибо большое! А вот чтобы подфорумы заработали, надо скрипт обновить?

0

180

Мэрилин Мэрис
Поменять ссылки в коде на оригинальные, ибо перезаливать их к себе смысла вообще никакого нет)

+1


Вы здесь » Единый форум поддержки » Информация сервиса » Поддержка HTTPS